Lots of things going on! Welcome!

Hello Everyone!

I hope you are doing well! Things are going pretty good on my end. Lots of exciting things going on. I had recently released some footage of some plants I shot, and the videos really sort of took off. Not so much on Instagram, but on Facebook surprisingly. Between all 6, I have about 120k views, most of them on just 3 of the videos.  The Biolapse Facebook page only had about 450 followers, and in the last week that number had tripled. I am pretty excited about all of this. I have quite a few new follows and wanted to take a moment and…..

Please allow me to introduce myself.

I seldom talk about my personal life or about myself on here, but I wanted to take a brake and do just that. My name is Chris Field and I live in Littleton Colorado. I have been into photography for about 8 years, and building motion control systems for timelapse photography for about 5 years. My friend Kyle and I started The Chronos Project and have sold Motion Control systems for time lapse photography all over the world. We even ran a successful Kickstarter for a focus control system, and eventually we both got burnt out on building and selling. This was a side project for each of us and we got spread so thin on selling, building, and such that we could not keep up on R&D. The competition marched on and we just sat back and let it go. It was fun, but I have a full-time career in telecommunications that I enjoy and pays well. I am a single father, Kyle has a family and a full time job. It just got to be too much, it was fun, but had to end. It was a welcome break. One day back in 2013 or I set up one of my Chronos rails in my basement and aimed the camera at a flower and filmed it. I was immediately hooked and knew that was the direction I wanted to take my work. Fast forward to now, and I have managed to take this to a pretty ridiculous level.  My goal is to be able to film plants at the same level as you see on Planet Earth. I am not there yet, but I am getting closer and closer. I have found this to be my ultimate hobby. There are no “off the shelf” systems that allow for long term studio timelapse. I have had to build most of my own tools. Lighting coordinators, environmental controls,  motion control systems, etc. I build my own sets, grow my own plants, I do all of this as a one man show. This means I get to wear many hats. Electrical and mechanical engineering, computer coding, set design, environmental control, photography, cinematography, timelapse photography, system maintenance, botany, etc.  There are a handful of people in the world that do this sort of work, and that means I get to show people things they have never seen before and film things that have never been filmed.  I hope one day I can do this as a career, but in the meantime it seems to keep me out of trouble and out of money.

 

I am extremely transparent about this sort of work, and If anybody else is interested in doing this sort of thing I am always happy to give tips and advice to save people a lot of the headaches and frustrations I already had to work through. At the moment I have multiple “Live Sets” that I have been growing the last few months and I am ramping up to start filming them. While those were growing I spent lots of time learning how to create lifelike environments for the plants, and this next project will take my work to an entirely new level.  I will share some bits here and there but this blog is primarily used for BTS stuff.

 

This post has ended up a bit long, so I will be adding some TL:DR (too long, didn’t read) summaries.
TL:DR – Welcome to my crazy hobby, I build robots and film plants. This will be a long post, and sometimes it gets a bit techie. Natalie Portman thinks I am totally hot.

 

In Today’s Episode, …..

Studio heat issues

Otto Woes

Lil Wayne Evolution

Project 3

Possible new robot

 

Studio Environment. (non-techie)

 

My studio generally heats up to about 85 degrees during the day. I am actually surprised it is not warmer than it is. Heat is generated not only by the 6 LED grow lights, but also by Otto’s motors, Motor drivers, and the computer that runs it. This is all in a fairly small room that is about 11x11ft.  85 may not seem a lot, but it I stressing some of the carnivorous plants so I have been looking at ways to get it down.

I has installed a 8 inch round duct that I ran which exhausts air outside using a pretty powerful fan. The duct goes from the closet in the studio through the ceiling, then the laundry room and connects to a exhaust outlet on the side of my house. The intended purpose of it was to provide some fresh air exchange as there are no working vents that run into that room. I generally have the vent fan (which is fairly powerful) to kick on for about half an hour and suck all the air out of that room and blow it outside late at night.  New air gets pulled in from the family room in the basement. The air quality is certainly better with this. I have tried setting this to kick on 15 minutes every half hour to help exhaust some of the heat out of the room, but all it seems to do is suck all the humidity out of the room instead.

I have a friend who loaned me a portable AC unit. It is a 12,000 BTU model with an exhaust outlet. I connected the exhaust outlet to the vent I had run to blow hot air out of the room while the AC sends cool air into the room. So far that has not had much of an effect. The room still sits around 80 degrees during the day. I am going to try to wrap some insulation around the exhaust ducting as it gets very hot and I think it is radiating heat back into the room and sort of cancelling itself out. Hopefully that will work.

I had also lowered the power output to all of Otto’s motors. Cutting the power in half has reduced the temp of the motors by about 50%. Yet the room remains warm. I think the grow lights are the main culprit to the heat. If they were not LED the room would probably be cranking up to the high 90’s.  Once I was done installing the AC and lowering the power to Otto’s motors, I started setting up a new timelapse capture and realized I had somehow busted Otto.

 

TL:DR = My studio is getting warm and might be harming the plants. I installed an AC unit and lowered the power output to my big robot Otto in efforts to try to cool the room with mixed success. I have a fine beard.

 

 

ROBOTS

I love me some robots! But those robots are a total and complete pain in the ass sometimes.

 

Otto Woes
(Extra dose of techie. Otto is my big robot, named after “Auto(pilot)” on Wall-E)

 

So after all that work on trying to actively cool the studio, Otto was a complete mess. There was this sort of a ticking sound when the motors would run, and the X axis was totally jacked. It moved very erratically. I spent about 2 hours trying to find the issue. Re-adjusting the dipswitches to adjust the power levels did not help. I swapped the command lines to the Pan and X axis to see whether or not the issue transferred to the Pan axis. That did not help, so the issue had to be further upstream. I replaced the cable between the DMC-16 and the stepper driver box, no good. I was getting pretty frustrated and figured I probably jacked up the X axis driver. Before swapping that driver out, I tried resetting the DMC-16. Boom. Fixed. Everything wan smooth as silk, I tested all motors and everything was good except the Pan axis.

 

If it is not one thing it is another. So I went through the troubleshooting process. Generally troubleshooting things is not that hard, but it is time consuming. It all boils down to the fundamental concept in electronics of the “Known open” and “known short”. I have found this concept works not only in electronics, but in troubleshooting telecommunications, data networks, and even bug hunting in code. After another 30 min fussing with the Pan axis I swapped the output from the DMC-16 (this is the stepper signal generator) from the 4th channel (the pan axis) to channel 10 which was a spare driver already installed. I then moved the plug from the motor from the 4th channel to the 10th. Basically, I just swapped everything to the spare driver and everything is working again.

 

The motor driver box I built which I call the MPS houses 10 Stepper drivers. Just a bit of a clarification, Stepper motors do not spin, they position. You tell it how far to move, where as DC motors spin as long as they have power. In order to control a stepper motor you have to have what is called a “Driver”. This driver accepts step and direction commands via pulses from the signal generator (The DMC-16 in this case) and will create various voltage patterns on its output. These cause the stepper motor to move clockwise, or counterclockwise, and how far you want. This gives steppers an advantage over DC motors as you can get them to move exactly where you want when you want giving you extremely high precision moves.  I have 2 types of drivers. The CWD556’s which are fairly powerful and allow me to get some pretty fast speeds. Then there are the Leadshine DM432c’s which are less powerful but they run oh so quiet and oh so smooth.  I had hoped when building Otto that I could get this rig moving at live video speeds, however the design of the Z axis (the elevator that raises and lowers the camera) causes some wobble which makes video work near impossible. I have 6 spare Leadshine drivers, so maybe this weekend I will replace the CWD556 with a spare Leadshine and call it a day.

 

I have also been encountering issues where the Canon 6D does not take an image when it is told. Luckily right now I am shooting and extremely slow growing Nepenthes (pitcher plant). The intervals are 30 min between frames, and if it misses a shot that stretches to an hour between the prior frame and the next one.  This will not be visible on the end result, but it is something I need to take care of.  Every time I do a camera test in Dragonframe it passes with flying colors. The camera is not dropping connection, so I am a little bit confused by this behavior. I did send some logs to the guys at Dragonframe (they are probably tired of hearing from me, but have been pretty responsive) to see if they can extrapolate anything from that data. I did read that using a non-powered USB 3.0 hub can cause problems, but considering the camera is not dropping connection, I don’t know if that is the issue. I did go ahead and order a pretty solid powered USB 3.0 hub from Anker which looks pretty solid to rule that our as a culprit.

 

The Canon 6D is also acting a bit squirrely. It just shuts off from time to time, which is obviously a problem as I may not catch it for half a day. When I first got the 6D, I had an aftermarket ac power supply which I had suspected was the issue. About 4 months ago I splurged on the overpriced Canon version it did seem to clear about 80% of this issue, but to this day once in a while I will check on it and find that it had shut down again. It may run for a few weeks without issue, or may shut off pretty quick. I am in the habit of occasionally turning it off and back on but that does not seem to really help a whole lot.  The power adapter comes in 3 parts. The plug to the wall, the AC-DC converter, and then a mock battery with a cable that plugs into the converter. The only part I replaced was the AC/DC converter unit. Due to the 90 degree L shape of the plug, I could not route the mock batteries cable through the channels in Otto. So to get around this problem I cut the cable near the battery pack and installed a connector enabling me to route the cable through the pan tilt frame on Otto. That MIGHT be where the issue is, so I got the canon brand Mock battery and cable which are intact and replaced the modified 3rd party battery. I am testing that out, if it stays on for a month solid, I’ll know this is the fix. However that leaves a cable hanging rather than nicely tucked in. Function over appearance, but having a long history in running cable, fiber, and routing cables in switch rooms I am somewhat picky about how it appears.

 

The fact is these systems are pretty complex and while it runs 99% of time the without issues, it can be pretty tough to root out some of these bugs, Vs, buying a turn-key setup for this sort of work which does not exist. (yet. More on that later)

 

TL:DR = The work being done to decrease the power to Otto’s motors caused problems with Otto. Fixing that issue caused a new issue, that is fixed. Still working through issues where the Canon 6D shuts off randomly. I think Otto has developed resentment towards Lil Wayne.

 

 

Lil’ Wayne
(Very Techie, this is my Smaller 4 axis robot, just recently reworked and kicking ass, just like the rapper Lil’Wayne)

 

So my smaller robot which I have dubbed “Lil Wayne” has made quite some progress as well.  This system runs a bit different than Otto.  The heart of this system is the highly capable eMotimo TB3 pan tilt system. The TB3 had never failed to impress me with its functionality and ease of use. However in the studio, the simple 3 point keyframing system just does not cut the mustard. When working up close with small plants the area that is in focus (this is called the Depth of Field, aka DOF) is usually very slim. Any motion where the camera adjusts location requires a tweak to the focus. The closer it is to the plant, the more it needs to be tweaked. In order to keep the focus on target, I rely on Keyframes.

 

Keyframes are basically just camera position and focus position targets. The first keyframe is where the camera starts out in its beginning position. I will then move the camera to the next location and mark keyframes so the system knows where the camera is supposed to be positioned, then move the camera again, lock it in, and again. The Dragonframe software remembers these positions and does the mathematics to make all of these targets into one smooth motion. Lenses seldom have linear focusing, meaning when you are focused up close and move ¼ of a turn, the focus does not shift the same as a mid distance focus target.  So if I have the camera positioned close to the object and lock in the keyframes for the pan, tilt, slide, and focus, then move it away from the target, and lock in those keyframes and run the routine, the object will start in focus and quickly drift out of focus, and then achieve focus again as the camera comes to its final position. To overcome this I normally have to add at least 7-8 keyframes on the focus to ensure it stays locked in the whole time. The TB3 does have the ability to control the Pan, Tilt and one extra motor, be it a linear slide or a focus motor or whatnot. The problem is the 3rd axis only allows for the beginning and ending keyframe. Therefore the stock firmware on the eMotimo TB3 can’t meet my needs. Luckily it does have the ability to integrate with Dragonframe, where it tethered to the computer via USB and I can put as many keyframes on there as I want.

 

As long as the eMotimo stays connected. Which was becoming a huge problem, as it would generally drop after about a day of shooting. I had tried everything. I replaced the USB with an active extension just in case my cable was too long and the signal was weak. No good. I adjusted the USB ports on the computer to ensure they were not going into power saving mode. Still it would drop. I tried all sorts of things to no avail. I tried loading the Dragonframe DFmoco software directly on the TB3 however eMotimo did not use the correct pinouts for the 3 motor drivers built into its custom PCB. I spend about an hour working on the code and was able to change the pins for the step commands, but not the direction. I am decent with coding things, but not that good at reverse engineering it. The answer finally came from Doug Urquhart  who had these same issues and was kind enough to forward a copy of the code where the pins were correct.  Once that was uploaded, the dropping issue disappeared, and it remained rock solid.

 

Just as a fun project I had designed a custom PCB that would replace the one within the eMotimo TB3, expanding its ability from driving 3 motors to driving 6. The prototype boards finally arrived and worked flawlessly! This also means the system is 100% dependent on Dragonframe, as the stock eMotimo firmware is no longer present. A part of me is a bit sad about that, as the eMotimo firmware has worked so well in the past as long as it was not required to be tethered to Dragonframe for more than a day at a time. But, on the other hand, now that new PCB controls the pan, tilt, linear, and focus without requiring a spare channel off the MPS which is the stepper driver box for Otto. It even provides 2 spare channels in case I want to run a rotary table or use another motor for effect like moving a light to get shadow tracking on my timelapse.

 

TL:DR = Lil’ Wayne was dropping connection to Dragonframe, in the end I gutted the electronics and replaced it with stuff of my own design, and it works flawlessly and now controls 6 motors instead of 3. My middle toe is longer than my big toe.

 

So now I have 2 fairly reliable motion control systems to film plants. But is that ever enough?

 

Project 3 (Mild Techie)

 

I have to constantly be building and engineering things. I just enjoy it too much. So I decided to take the challenge on designing and building a very tight budget 4 axis system to interface with Dragonframe. This would have all the same functionality as Lil’ Wayne, and the goal is to see how cheap it can be done. Otto ran me north of 18k to build. But that is a full out robot with pan, tilt, roll, x, y, x, focus, and 3d stereoscopic capabilities.  Pricing out Lil’ Wayne, the eMotimo, Chronos Micro rail, and Lens apparatus that would run about 2-3 grand to put together. I wanted to see if I could construct a system that offers the same ability for far less.

 

Enter Project 3.  I already had designed and tested the 6 axis PCB that interfaces with Dragonframe. That was designed to fit inside an eMotimo, but there is no reason it cannot work on another robot. So that part is covered, all I needed was the hardware to build a Pan/Tilt/Linear/Focus rig. My target budget for the whole Moco system is $500 or less, and I think I have it worked out, and will come in well under that budget. This is a flyweight system, meaning no heavy DSLR but I prefer to use smaller mirrorless cameras.  My goal is about 15 inches of linear motion (longer slide rails just get in the way for this work, and generally a distance of 15 inches is more than enough), accurate pan / tilt, and something that has never been done before, a universal lens mounted focus puller.  You probably see I talk about focus a lot, and that is because it is the most critical function for the type of work I do. There are other lens motors out there, but they all attach by those stupid 15mm rod systems. The problem with is normally the fact the lens motor connects to the rod, which connects to a platform that holds the rods. The camera attaches to the platform, and the lens attaches to the camera. Every time I have dealt with this setup, if you shift directions on the focus the lens tugs and moves. Kyle and I made hundreds of Lens Apparatus’s and we never see them used, and I believe it is because of the lens tug. There are some ways around this issue, but to me the best way to tackle this is to attach the lens motor direct to the lens, eliminating any and all potential lens tug. This is how I achieve so many focus pulls that are as buttery smooth. Many of my videos might have 8-12 keyframes on the focus, but when you watch the resulting footage, the lens work is virtually non-existent, rather, the subject stays in perfect focus the entire time.  Right now I have a pair of Nikkor 60mm f/2.8 Macro lenses, and custom designed focus control mounts on each one (The orange thing you see on the lenses on my motion control systems).  The problem is these mounts ONLY fit those lenses. For the last year I have kept trying to come up with designs for a focus puller that is super lightweight, accurate, and that can mount to any lens directly. My latest design turns out to be incredibly simple with just 4 inexpensive off-the-shelf parts, and I am very optimistic.
If Project 3 pans out, I might be willing to build them for someone using Dragonframe that would be interested in a 4 axis rig. All you would need to do is attach it to a tripod, add the camera, run USB from the on-board controller to a Laptop running Dragonframe and voila, instant motion control for animation or timelapse photography with 2 extra channels that could be used for various effects, and they would be very inexpensive. That is of course, if it works. They would probably not be a good fit for field work as they would be powered off AC and require a computer to control.

 

TL:DR = I am designing a new very low cost robot with Pan/Tilt/Linear/Focus control that can be controlled via computer running Dragonframe software. Dang yer lazy. 

 

A new Robot to play with? (Non Techie)

 

Another exciting bit of news! I might be adding yet another new robot to my arsenal. I was approached by a brand (not telling who just yet, but they have a very solid name) who was wondering if I would be interested in testing out a loaner system for my next project. It’s not 100% yet, but I think there Is a decent chance I will get to showcase their gear 😊 I would be very excited to try this out as it is a complete enclosed ecosystem, hardware software, everything, not a piecemeal setup as I am used to working with.

 

One thought on “Lots of things going on! Welcome!”

  1. …you are a time-lapse motion-control plant growing and recording master. Wish I could apply some of this to my construction site work. Now that would be awesome! I do have a unit I call Frankenstein and it works well but timing it is a challenge.

    Keep on clicking!

Leave a Reply